Vulnérabilités dans des produits VMware

De multiples vulnérabilités ont été découvertes dans les produits VMware. Elles peuvent permettre à un attaquant de provoquer une exécution de code arbitraire, un déni de service, une atteinte à l'intégrité et à la confidentialité des données.

CVE-2020-3992 [Score CVSS v3 : 9.8] : Une vulnérabilité de type “use-after-free” a été découverte dans le composant OpenSLP utilisé dans VMware ESXi. Elle peut permettre à un attaquant distant ayant accès au port 427 d’une machine ESXi de provoquer une exécution de code arbitraire

CVE-2020-3993 [Score CVSS v3 : 7.5] : Une vulnérabilité a été découverte dans VMware NSX-T. Elle est due aux autorisations accordées à un hôte KVM pour télécharger et installer des paquets depuis un manager NSX. Un attaquant en position d’homme du milieu peut exploiter cette vulnérabilité afin de compromettre un noeud de transport.

CVE-2020-3994 [Score CVSS v3 : 7.5] : Une vulnérabilité pouvant conduire à une corruption de session a été découverte dans VMware vCenter Server. Elle est due à une non-vérification de certificat par la fonctionnalité de mise à jour de vCenter Server Appliance Management Interface. Un attaquant positionné entre vCenter Server et un dépôt de mise à jour peut exploiter cette vulnérabilité afin de provoquer une corruption de session lorsque  vCenter Server Appliance Management Interface est utilisé pour faire une mise à jour.

Informations
+

Risques

  • Exécution de code arbitraire

  • Déni de service

  • Atteinte à l'intégrité des données

  • Atteinte à la confidentialité des données

Criticité

  • Score CVSS v3 : 9.8 maximum

Existence d’un code d’exploitation

  • Aucun code d’exploitation n’est disponible publiquement

Composants vulnérables

  • ESXi 7.0.x versions antérieures à ESXi_7.0.1-0.0.16850804

  • ESXi 6.7.x versions antérieures à ESXi670-202010401-SG

  • ESXi 6.5.x versions antérieures à ESXi650-202010401-SG

  • NSX-T 3.x versions antérieures à 3.0.2

  • NSX-T 2.5.x versions antérieures à 2.5.2.2.0

  • Fusion 11.x versions antérieures à 11.5.6

  • Workstation 15.x toutes versions

  • VMware Cloud Foundation 4.x versions antérieures à 4.1

  • VMware Cloud Foundation 3.x versions antérieures à 3.10.1.1

  • vCenter 6.7.x versions antérieures à 6.7 U3

  • vCenter 6.5.x versions antérieures à 6.5 U3K

CVE

  • CVE-2020-3981

  • CVE-2020-3982

  • CVE-2020-3992

  • CVE-2020-3993

  • CVE-2020-3994

  • CVE-2020-3995


Recommandations
+

Mise en place de correctifs de sécurité

  • Mettre à jour vers une version non vulnérable

Solution de contournement

  • Aucune solution de contournement