Vulnérabilités dans le système d’exploitation Cisco IOS XR

CVE-2021-34719 [Score CVSS v3.1 : 7.8]
Une vulnérabilité dans l'interface CLI du logiciel Cisco IOS XR. Cette faille est due à une validation insuffisante des arguments de la ligne de commande. Son exploitation pourrait permettre à un attaquant local et authentifié d’obtenir les privilèges racines sur un appareil affecté.

CVE-2021-34728 [Score CVSS v3.1 : 7.8]
Une vulnérabilité dans l'interface CLI du logiciel Cisco IOS XR. Son exploitation pourrait permettre à un attaquant local et authentifié d’obtenir les privilèges racines sur un appareil affecté. Cette faille est due à une validation insuffisante des entrées de commandes fournies par un utilisateur.

CVE-2021-34718 [Score CVSS v3.1 : 8.1]
Une vulnérabilité dans le processus du serveur SSH du logiciel Cisco IOS XR. Cette faille est due à une validation d'entrée insuffisante des arguments fournis par l'utilisateur pour une méthode de transfert de fichiers spécifique. Son exploitation pourrait permettre à un attaquant distant et authentifié d'écraser et de lire des fichiers arbitraires sur le périphérique local en spécifiant des paramètres Secure Copy Protocol (SCP) lors de l'authentification à un périphérique.

CVE-2021-34720 [Score CVSS v3.1 : 8.6]
Une vulnérabilité dans le répondeur des accords de niveau de service IP (IP SLA) et dans le protocole TWAMP (Two-Way Active Measurement Protocol) du logiciel Cisco IOS XR. Cette faille existe car les échecs de création de socket sont mal gérés pendant les processus IP SLA et TWAMP. Son exploitation pourrait permettre à un attaquant distant et non authentifié d'épuiser la mémoire des paquets du périphérique ou de faire planter le processus IP SLA, ce qui entraînerait un déni de service.

CVE-2021-34713 [Score CVSS v3.1 : 7.4]
Une vulnérabilité dans le code punt de couche 2 du logiciel Cisco IOS XR exécuté sur les routeurs de services d'agrégation Cisco ASR 9000 Series. Cette faille est due à un traitement incorrect de certaines trames Ethernet qui provoquent une boucle de rotation pouvant rendre les processeurs réseau insensibles. Son exploitation pourrait permettre à un attaquant adjacent au réseau et non authentifié de provoquer le redémarrage de la carte de ligne affectée.

Informations
+

Risques

  • Elévation de code arbitraire
  • Déni de service
  • Atteinte à l’intégrité des données
  • Atteinte à la confidentialité des données

Criticité

  • Scores CVSS v3.1 : 8.6 max

Existence d’un code d’exploitation

  • Aucun code d'exploitation n’est disponible publiquement à l’heure actuelle.

Composants vulnérables

  • Cisco IOS XR versions antérieures à 7.3.2
  • Cisco IOS XR versions antérieures à 7.4.1

CVE


Recommandations
+

Mise en place de correctifs de sécurité

  • Mettre à jour les composants impactés conformément aux instructions de Cisco.

Solution de contournement

  • Aucune solution de contournement n’est disponible publiquement à l’heure actuelle.